const regex = new RegExp('\\bfunction\\b \\s*[a-zA-Z0-9._]*
\\(
(
(?:
(?:[a-zA-Z_][a-zA-Z0-9_]*|\\.\\.\\.)
(?: ,\\s* (?:[a-zA-Z_][a-zA-Z0-9_]*|\\.\\.\\.) )*
)?
)
\\)', 'g')
const str = `function f(aaaaaaa, bbbbbbbb, cccccccc, ddddddd eeeeee)
function f(aaaaaaa, bbbbbbbb, cccccccc, ddddddd, eeeeee)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}