import re
regex = re.compile(r"""
\bfunction\b \s*[a-zA-Z0-9._]*
\(
(
(?:
(?:[a-zA-Z_][a-zA-Z0-9_]*|\.\.\.)
(?: ,\s* (?:[a-zA-Z_][a-zA-Z0-9_]*|\.\.\.) )*
)?
)
\)
""", flags=re.VERBOSE)
test_str = ("function f(aaaaaaa, bbbbbbbb, cccccccc, ddddddd eeeeee)\n"
"function f(aaaaaaa, bbbbbbbb, cccccccc, ddddddd, eeeeee)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")