$re = '/\bfunction\b \s*[a-zA-Z0-9._]*
\(
(
(?:
(?:[a-zA-Z_][a-zA-Z0-9_]*|\.\.\.)
(?: ,\s* (?:[a-zA-Z_][a-zA-Z0-9_]*|\.\.\.) )*
)?
)
\)/x';
$str = 'function f(aaaaaaa, bbbbbbbb, cccccccc, ddddddd eeeeee)
function f(aaaaaaa, bbbbbbbb, cccccccc, ddddddd, eeeeee)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);