import Foundation
let pattern = #"""
\bfunction\b \s*[a-zA-Z0-9._]*
\(
(
(?:
(?:[a-zA-Z_][a-zA-Z0-9_]*|\.\.\.)
(?: ,\s* (?:[a-zA-Z_][a-zA-Z0-9_]*|\.\.\.) )*
)?
)
\)
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: .allowCommentsAndWhitespace)
let testString = #"""
function f(aaaaaaa, bbbbbbbb, cccccccc, ddddddd eeeeee)
function f(aaaaaaa, bbbbbbbb, cccccccc, ddddddd, eeeeee)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)