const regex = /(?i)^(?=.*[a-z])[a-z0-9]{8,20}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?i)^(?=.*[a-z])[a-z0-9]{8,20}$', 'gm')
const str = `abc987dfsgsdf
12345678
Absdf9898798
dasfkjhslgfkha`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);