use strict;
my $str = 'abc987dfsgsdf
12345678
Absdf9898798
dasfkjhslgfkha';
my $regex = qr/(?i)^(?=.*[a-z])[a-z0-9]{8,20}$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";