import Foundation
let pattern = #"(?i)^(?=.*[a-z])[a-z0-9]{8,20}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
abc987dfsgsdf
12345678
Absdf9898798
dasfkjhslgfkha
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)