# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?i)^(?=.*[a-z])[a-z0-9]{8,20}$"
test_str = ("abc987dfsgsdf\n"
"12345678\n"
"Absdf9898798\n"
"dasfkjhslgfkha")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.