re = /(?i)^(?=.*[a-z])[a-z0-9]{8,20}$/m
str = 'abc987dfsgsdf
12345678
Absdf9898798
dasfkjhslgfkha'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result