use strict;
my $str = '12344A.ffdsaaddd
12(3<44>aaav
12344aaavq
fffffffffffasdfasdfas
A**.2344aaavq';
my $regex = qr/[(](.*?)[>]/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";