import Foundation
let pattern = #"[(](.*?)[>]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
12344A.ffdsaaddd
12(3<44>aaav
12344aaavq
fffffffffffasdfasdfas
A**.2344aaavq
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)