re = /[(](.*?)[>]/m
str = '12344A.ffdsaaddd
12(3<44>aaav
12344aaavq
fffffffffffasdfasdfas
A**.2344aaavq'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result