// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[(](.*?)[>]").unwrap();
let string = "12344A.ffdsaaddd
12(3<44>aaav
12344aaavq
fffffffffffasdfasdfas
A**.2344aaavq";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}