#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[2-9]{1}\d{0,3}$"
Local $sString = "1" & @CRLF & _
"2" & @CRLF & _
"3" & @CRLF & _
"4" & @CRLF & _
"1000" & @CRLF & _
"2000" & @CRLF & _
"2565" & @CRLF & _
"32+6253" & @CRLF & _
"62" & @CRLF & _
"0232"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")