package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[2-9]{1}\d{0,3}$`)
var str = `1
2
3
4
1000
2000
2565
32+6253
62
0232`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}