const regex = /^[2-9]{1}\d{0,3}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[2-9]{1}\\d{0,3}$', 'gm')
const str = `1
2
3
4
1000
2000
2565
32+6253
62
0232`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}