import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[2-9]{1}\\d{0,3}$";
final String string = "1\n"
+ "2\n"
+ "3\n"
+ "4\n"
+ "1000\n"
+ "2000\n"
+ "2565\n"
+ "32+6253\n"
+ "62\n"
+ "0232";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}