import re
regex = re.compile(r"^[2-9]{1}\d{0,3}$", flags=re.MULTILINE)
test_str = ("1\n"
"2\n"
"3\n"
"4\n"
"1000\n"
"2000\n"
"2565\n"
"32+6253\n"
"62\n"
"0232")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")