using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w+)\(""([^""]+)""\)";
string substitution = @"""$1(\\""$2\\"")""";
string input = @"
{
""_id"" : ObjectId(""5733b42c66beadec3cbcb9a4""),
""date"" : ISODate(""2016-05-11T22:37:32.341Z""),
""name"" : ""KJ""
}";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}