import Foundation
let pattern = #"(\w+)\("([^"]+)"\)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
{
"_id" : ObjectId("5733b42c66beadec3cbcb9a4"),
"date" : ISODate("2016-05-11T22:37:32.341Z"),
"name" : "KJ"
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""$1(\\"$2\\")""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)