// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(\w+)\("([^"]+)"\)"#).unwrap();
let string = "
{
\"_id\" : ObjectId(\"5733b42c66beadec3cbcb9a4\"),
\"date\" : ISODate(\"2016-05-11T22:37:32.341Z\"),
\"name\" : \"KJ\"
}";
let substitution = "\"$1(\\\\\"$2\\\\\")\"";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}