import re
regex = re.compile(r"(\w+)\(\"([^\"]+)\"\)")
test_str = ("\n"
"{\n"
" \"_id\" : ObjectId(\"5733b42c66beadec3cbcb9a4\"),\n"
" \"date\" : ISODate(\"2016-05-11T22:37:32.341Z\"),\n"
" \"name\" : \"KJ\"\n"
"}")
subst = "\"$1(\\\\\"$2\\\\\")\""
result = regex.sub(subst, test_str)
if result:
print(result)