$re = '/(\w+)\("([^"]+)"\)/';
$str = '
{
"_id" : ObjectId("5733b42c66beadec3cbcb9a4"),
"date" : ISODate("2016-05-11T22:37:32.341Z"),
"name" : "KJ"
}';
$subst = "\"$1(\\\"$2\\\")\"";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;