const regex = /(\w+)\("([^"]+)"\)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\w+)\\("([^"]+)"\\)', 'g')
const str = `
{
"_id" : ObjectId("5733b42c66beadec3cbcb9a4"),
"date" : ISODate("2016-05-11T22:37:32.341Z"),
"name" : "KJ"
}`;
const subst = `"$1(\\"$2\\")"`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);