#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!www\.|(?:http|ftp)s?://|[A-Za-z]:\\|//).*"
Local $sString = "y protocol or double slash //" & @CRLF & _
"C:\File" & @CRLF & _
"about.html" & @CRLF & _
"tutorial1/" & @CRLF & _
"tutorial1/2.html" & @CRLF & _
"/" & @CRLF & _
"/experts/ " & @CRLF & _
"../ " & @CRLF & _
"../experts/ " & @CRLF & _
"../../../ " & @CRLF & _
"./ " & @CRLF & _
"./about.html" & @CRLF & _
"http://google.com" & @CRLF & _
"www.google.com" & @CRLF & _
"//dub-server1/mynode"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")