re = /^(?!www\.|(?:http|ftp)s?:\/\/|[A-Za-z]:\\|\/\/).*/m
str = 'y protocol or double slash //
C:\\File
about.html
tutorial1/
tutorial1/2.html
/
/experts/
../
../experts/
../../../
./
./about.html
http://google.com
www.google.com
//dub-server1/mynode'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end