$re = '/^(?!www\.|(?:http|ftp)s?://|[A-Za-z]:\\\\|//).*/m';
$str = 'y protocol or double slash //
C:\\File
about.html
tutorial1/
tutorial1/2.html
/
/experts/
../
../experts/
../../../
./
./about.html
http://google.com
www.google.com
//dub-server1/mynode';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);