import re
regex = re.compile(r"^(?!www\.|(?:http|ftp)s?://|[A-Za-z]:\\|//).*", flags=re.MULTILINE)
test_str = ("y protocol or double slash //\n"
"C:\\File\n"
"about.html\n"
"tutorial1/\n"
"tutorial1/2.html\n"
"/\n"
"/experts/ \n"
"../ \n"
"../experts/ \n"
"../../../ \n"
"./ \n"
"./about.html\n"
"http://google.com\n"
"www.google.com\n"
"//dub-server1/mynode")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")