import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!www\\.|(?:http|ftp)s?://|[A-Za-z]:\\\\|//).*";
final String string = "y protocol or double slash //\n"
+ "C:\\File\n"
+ "about.html\n"
+ "tutorial1/\n"
+ "tutorial1/2.html\n"
+ "/\n"
+ "/experts/ \n"
+ "../ \n"
+ "../experts/ \n"
+ "../../../ \n"
+ "./ \n"
+ "./about.html\n"
+ "http://google.com\n"
+ "www.google.com\n"
+ "//dub-server1/mynode";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}