#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^[+-]?(?!\.(?!\d)|$)\d*(?:\.\d*)?(?:(?<=[\d.])e[+-]?\d+)?$"
Local $sString = "0" & @CRLF & _
"." & @CRLF & _
".0" & @CRLF & _
"0." & @CRLF & _
"0.0" & @CRLF & _
"1" & @CRLF & _
"123456.789" & @CRLF & _
"" & @CRLF & _
"e123" & @CRLF & _
"1e4" & @CRLF & _
"1e4.5" & @CRLF & _
"1.4e4" & @CRLF & _
"1.4" & @CRLF & _
"1.4e" & @CRLF & _
"1.4e0" & @CRLF & _
"1.e4" & @CRLF & _
".e4" & @CRLF & _
"0.e4" & @CRLF & _
"-" & @CRLF & _
"1e-4" & @CRLF & _
"1e+4" & @CRLF & _
"1e-" & @CRLF & _
"1e+"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")