use strict;
my $str = '0
.
.0
0.
0.0
1
123456.789
e123
1e4
1e4.5
1.4e4
1.4
1.4e
1.4e0
1.e4
.e4
0.e4
-
1e-4
1e+4
1e-
1e+';
my $regex = qr/^[+-]?(?!\.(?!\d)|$)\d*(?:\.\d*)?(?:(?<=[\d.])e[+-]?\d+)?$/imp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}