using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[+-]?(?!\.(?!\d)|$)\d*(?:\.\d*)?(?:(?<=[\d.])e[+-]?\d+)?$";
string input = @"0
.
.0
0.
0.0
1
123456.789
e123
1e4
1e4.5
1.4e4
1.4
1.4e
1.4e0
1.e4
.e4
0.e4
-
1e-4
1e+4
1e-
1e+";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}