const regex = /^[+-]?(?!\.(?!\d)|$)\d*(?:\.\d*)?(?:(?<=[\d.])e[+-]?\d+)?$/igm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[+-]?(?!\\.(?!\\d)|$)\\d*(?:\\.\\d*)?(?:(?<=[\\d.])e[+-]?\\d+)?$', 'igm')
const str = `0
.
.0
0.
0.0
1
123456.789
e123
1e4
1e4.5
1.4e4
1.4
1.4e
1.4e0
1.e4
.e4
0.e4
-
1e-4
1e+4
1e-
1e+`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}