# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(^[^_]*_[^_]+|\G[^_]+)(?:_|$)/$1\n/gm;t' <<< "A_B_C_D_E_F"