$re = '/(^[^_]*_[^_]+|\G[^_]+)(?:_|$)/m';
$str = 'A_B_C_D_E_F';
$subst = "$1\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;