re = /(^[^_]*_[^_]+|\G[^_]+)(?:_|$)/m
str = 'A_B_C_D_E_F'
subst = '$1\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result