use strict;
my $str = 'A_B_C_D_E_F';
my $regex = qr/(^[^_]*_[^_]+|\G[^_]+)(?:_|$)/mp;
my $subst = '$1\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";