const regex = /(^[^_]*_[^_]+|\G[^_]+)(?:_|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^[^_]*_[^_]+|\\G[^_]+)(?:_|$)', 'gm')
const str = `A_B_C_D_E_F`;
const subst = `$1\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);