using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^[^_]*_[^_]+|\G[^_]+)(?:_|$)";
string substitution = @"$1\n";
string input = @"A_B_C_D_E_F";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}