using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?P<name>[\s\w]+){1}\s(?P<phone>\d+)?\s(?P<email>[a-zA-Z0-9_.+-]+@[a-zA-Z0-9-]+\.[a-zA-Z0-9-.]+)?\s+(?:C:\s*(?:\s*(?P<company>(?:[\s\w]+))))?\s+(?:N:\s*(?P<notes>[\s\w]+))";
string input = @"Artem Gladkov 89299992886 gladkov@kaspersky.com C: Kaspersky Awes N: Notes from me f";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}