import re
regex = re.compile(r"(?P<name>[\s\w]+){1}\s(?P<phone>\d+)?\s(?P<email>[a-zA-Z0-9_.+-]+@[a-zA-Z0-9-]+\.[a-zA-Z0-9-.]+)?\s+(?:C:\s*(?:\s*(?P<company>(?:[\s\w]+))))?\s+(?:N:\s*(?P<notes>[\s\w]+))", flags=re.MULTILINE)
test_str = "Artem Gladkov 89299992886 gladkov@kaspersky.com C: Kaspersky Awes N: Notes from me f"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")