import Foundation
let pattern = #"(?P<name>[\s\w]+){1}\s(?P<phone>\d+)?\s(?P<email>[a-zA-Z0-9_.+-]+@[a-zA-Z0-9-]+\.[a-zA-Z0-9-.]+)?\s+(?:C:\s*(?:\s*(?P<company>(?:[\s\w]+))))?\s+(?:N:\s*(?P<notes>[\s\w]+))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"Artem Gladkov 89299992886 gladkov@kaspersky.com C: Kaspersky Awes N: Notes from me f"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)