import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<name>[\\s\\w]+){1}\\s(?P<phone>\\d+)?\\s(?P<email>[a-zA-Z0-9_.+-]+@[a-zA-Z0-9-]+\\.[a-zA-Z0-9-.]+)?\\s+(?:C:\\s*(?:\\s*(?P<company>(?:[\\s\\w]+))))?\\s+(?:N:\\s*(?P<notes>[\\s\\w]+))";
final String string = "Artem Gladkov 89299992886 gladkov@kaspersky.com C: Kaspersky Awes N: Notes from me f";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}