re = /(?P<name>[\s\w]+){1}\s(?P<phone>\d+)?\s(?P<email>[a-zA-Z0-9_.+-]+@[a-zA-Z0-9-]+\.[a-zA-Z0-9-.]+)?\s+(?:C:\s*(?:\s*(?P<company>(?:[\s\w]+))))?\s+(?:N:\s*(?P<notes>[\s\w]+))/m
str = 'Artem Gladkov 89299992886 gladkov@kaspersky.com C: Kaspersky Awes N: Notes from me f'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end