#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(\b(\w*)(logic(?:al)?))"
Local $sString = "Meteorologic|Meteorological"
Local $sSubst = "0=\0\n1=\1\n2=\2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)