re = /(\b(\w*)(logic(?:al)?))/
str = 'Meteorologic|Meteorological'
subst = '0=\\0\\n1=\\1\\n2=\\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result