import Foundation
let pattern = #"(\b(\w*)(logic(?:al)?))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Meteorologic|Meteorological"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"0=\0\n1=\1\n2=\2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)