// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\b(\w*)(logic(?:al)?))").unwrap();
let string = "Meteorologic|Meteorological";
let substitution = "0=\\0\\n1=\\1\\n2=\\2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}