$re = '/(\b(\w*)(logic(?:al)?))/';
$str = 'Meteorologic|Meteorological';
$subst = "0=\0\n1=\1\n2=\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;