const regex = /(\b(\w*)(logic(?:al)?))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\b(\\w*)(logic(?:al)?))', 'g')
const str = `Meteorologic|Meteorological`;
const subst = `0=\0\n1=\1\n2=\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);